Intermittent Availability on parkwhiz.com and bestparking.com

Incident Report for ParkWhiz

Resolved

The issue has been resolved. The team will continue to monitor.
Posted Jun 06, 2025 - 13:00 CDT

Monitoring

A fix has been deployed for ParkWhiz and BestParking to restore services. The team is monitoring.
Posted Jun 06, 2025 - 09:55 CDT

Identified

We are aware of an issue causing intermittent availability on ParkWhiz and BestParking. The team is working to remediate the issue as soon as possible.
Posted Jun 06, 2025 - 09:48 CDT
This incident affected: ParkWhiz Website.