DDoS Attack

Incident Report for ParkWhiz

Resolved

We’ve implemented additional mitigation measures and are cautiously optimistic that the issue has been resolved. We’ll continue monitoring closely and remain attentive to any unexpected behavior.
Posted Jun 02, 2025 - 21:05 CDT

Monitoring

The team has implemented mitigation for the attack and services should be largely available. The attack is ongoing but is successfully being mitigated. We will continue to monitor and implement additional mitigation as necessary.
Posted Jun 02, 2025 - 10:54 CDT

Update

The ParkWhiz platform is currently experiencing a service disruption. Our teams are actively working to resolve an issue caused by a Distributed Denial of Service (DDoS) attack.

Please be assured that this type of attack is designed to overwhelm our services and does not compromise your data or security. You and your customer's information remains safe.

Our engineering teams are fully engaged in mitigating the attack and restoring full service as quickly as possible. You may experience intermittent access or slowness with our services at this time. We sincerely apologize for any inconvenience this causes.

We'll provide our next update within two hours or sooner if new information becomes available. Thank you for your patience and understanding as we work to resolve this.
Posted Jun 02, 2025 - 09:32 CDT

Investigating

We're experiencing a significant DDoS attack impacting APIs. Mitigation is in progress
Posted Jun 02, 2025 - 04:56 CDT
This incident affected: Arrive API v4, ParkWhiz Website, ParkWhiz App, Admin and Seller Portal, and Affiliate API.