DDoS attack

Incident Report for ParkWhiz

Resolved

This incident has been resolved.
Posted Jun 01, 2025 - 22:33 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 01, 2025 - 20:53 CDT

Update

We're continuing to see elevated response times as we work to mitigate
Posted Jun 01, 2025 - 19:34 CDT

Monitoring

Systems have returned to stable and we are monitoring
Posted Jun 01, 2025 - 13:03 CDT

Investigating

We're experiencing a significant DDoS attack impacting APIs. Mitigation is in progress
Posted Jun 01, 2025 - 09:44 CDT
This incident affected: Arrive API v4, ParkWhiz Website, and ParkWhiz App.